requisites Node 0.6+ NPM RequireJS Have…